Installation Issues

Post here for queries regarding setup problems.

We recommend you try using the troubleshooting instructions here first if you have not already.

Please try to list as much about the problem as you can (OS distribution, versions, motor setup et cetera), the more we know the easier it is to help :)

Hi - I think I've installed properly - the GUI controller works - but when I try to import ZeroBorg in python, I get no module named ZeroBorg. WHat step have I missed?

I used a fresh install of raspbian.

Thanks,

Ben

Images: 

I needed my python code to be in the zeroborg folder. :)

piborg's picture

As you have found out, the error simply means that Python does not know where to find the ZeroBorg.py file.

There are three main ways around this problem:

  1. Run Python from the ~/zeroborg directory.
    This is what we would normally suggest as well.
  2. Copy the ZeroBorg.py script into the directory you are using.
    This is best when you want to share your scripts with others.
  3. Tell Python where to find the script first.
    This makes life easier, but requires adding a couple of lines to each script:
    import sys
    sys.ptah.append('/home/pi/zeroborg')
    import ZeroBorg
    

Hi,
I have connected a 9v battery to V+ and GND connectors and can confirm the 9v is available across the switch. When I check the voltage at the 6 pin connector to which the pi zero would connect I do not get any voltage. Is there something additional on the board other than the 2 jumpers across the switch which would cause this, I have the jumpers set as per the Getting Started section,
Thanks Jane

piborg's picture

Which model of ZeroBorg do you have?

If you have a KS2 then it should be providing 5V power to the 6-pin connectors with the two jumpers fitted:

If you have a KS1 then the ZeroBorg does not provide the 5V power, instead it expects it to be supplied to the Raspberry Pi from another device:

Thank you for responding so quickly.
That would explain my problem I have a KS1 I believe I should have a KS2, really appreciate your guidance and the quick turnaround saved me from excessive headbanging :)
Jane

Is it ok to add the 5v regulator to the KS1 and if so do I need to alter any links?

piborg's picture

Yes, you can solder in a 5V DC/DC regulator into the set of three holes on a ZeroBorg KS1 to add the ability to power a Raspberry Pi.

You do not need to solder or modify any other part of the board.
Make sure the DC/DC is fitted the same way as shown on the KS2, if fitted wrong it can cause damage.

Thanks for your help, all worked fine when I realised the + and - holes on the board are for mounting and not connected. Now connected battery wires to screw connectors!

Ordered the KS1 before I realized that I would need the DC/DC converter. Ordered the 9V to 5V DCDC converter and have installed it on the Piborg Zero. Also installed the 9V battery terminals and installed them as well. (See pictures) There are no solder drips or bad connections. I have 9V on the power terminal, so I know that at least the Piborg Zero is getting power.

I am not getting any voltage into or out of the converter. Since there is not an installation video I went off of the pictures on of the KS2/KS3.

So, is there a jumper that must be connected? Did I miss something?

Thanks for the help,
Tom

Images: 
piborg's picture

Looking closely it seems like the connection between the battery and the fuse is not soldered. From how it looks this might not be making any connection at all. If so this would explain the problem.

I have attached an image with the tab in question circled. We would recommend soldering all three tabs on both of the 9V terminals for added stability anyway. With only one soldered you run the risk of braking the terminals off if your robot collides with something.

Images: 

Thanks for your fast reply. It's soldered from the top. All pins are soldered. I believe that this must be connected as there is 9V on the power pins as shown in the 3rd picture.

piborg's picture

The connection from that fuse is the one that eventually gets to the DC/DC pin. It is possible one of the components is not making a good connection.

If you could measure the voltage between the GND terminal and each of these points:

  1. Before the fuse
  2. After the fuse
  3. At the SW jumper - you should be able to probe the metal part with it in place
  4. Before the diode
  5. After the diode
  6. At the DC/DC pin

Points labelled in the image below.

If everything is working normally these should all read the same as the battery voltage.

Images: 

Ok, well, had 9.4V at each of the locations. Still no 5V out.

Dabbed a bit more solder on the pin and voila! 5V out of the converter!

Thanks for the help and the awesome diagnostic drawings!

Hi,

I have an issue with power supply for raspberry pi (using ZeroBorg KS2 with DC/DC).
Rasperry pi is booting normally, but after initialize of ZeroBorg and first power on of the motors raspberry pi is rebooting unexpected.

My setup:
- power supply from 6 AA NiMh accus to ZeroBorg
- raspberry pi directly connected to ZeroBorg
- 4 motors
- 7,8V measured on input
- 4,9V measured on the power supply of raspberry pi

Can you give me some hint what might be an issue here?

piborg's picture

It sounds like the current needed by the four motors and the DC/DC at the same time is probably too much for the 6x AAs to handle.

When the batteries cannot keep up with the current demand they produce a lower voltage to compensate. In this case the necessary current is large enough that it is causing the batteries to get below 7 V, causing the DC/DC to turn off.

The exact current required depends on the motors themselves, but it is likely that they need a larger current to start them moving than they will need to keep moving. This would mean the power dip is temporary, but still long enough to loose the 5V output and cause the Pi to reset.

I would suggest moving to 8x AAs, this will allow the battery voltage to dip a long way before causing the reset issue. This should stop the Pi resetting :)

OK, thanks for the prompt feedback. I will give it a try with 8xAA. I was worried it might be too much for ZeroBorg and agraid to fry it. I'll let you know if it worked out.

piborg's picture

When the batteries are fully charged it will be very close to the 10.8 V limit, but still within:

~1.3 V × 8 ≈ 10.4 V

Hi
I have installed the default code and added a controller and for some reason it turns faster one way than the other. What is likely to cause this?
Thanks
Nic

piborg's picture

On the ZeroBorg this is a slight difference in power values between running motors with positive power and negative power. Put simply the motors run slightly faster in one direction than the other.

You can solve the turning difference by adjusting the code so that all the motors use the same direction for driving forwards.

First open zbJoystick.py in an editor and look for these lines:

                # Set the motors to the new speeds
                ZB.SetMotor1(-driveLeft * maxPower)
                ZB.SetMotor2(-driveLeft * maxPower)
                ZB.SetMotor3(driveRight * maxPower)
                ZB.SetMotor4(driveRight * maxPower)

What you need to do is add a - sign in front of the driveRight values, like this:

                # Set the motors to the new speeds
                ZB.SetMotor1(-driveLeft * maxPower)
                ZB.SetMotor2(-driveLeft * maxPower)
                ZB.SetMotor3(-driveRight * maxPower)
                ZB.SetMotor4(-driveRight * maxPower)

Once you have changed the code swap the + and - connections on motors 3 and 4 on the ZeroBorg.
This will make them move in the correct direction again.

Subscribe to Comments for "Installation Issues"