Yetiborg V2 problem

Hi, I bought a yetiborg V2 for my son this christmas but I cannot get it to work properly. The robot is assembled correctly and all 4 motors work - the canned sequence makes all the motors move in what appears to be the right order for the turns. However, when trying to move forward only the rear two wheels move and the front two are locked which means the robot does not move forward except in a very jerky movement as the front wheels prevent the robot moving. using the web UI, forward does the same thing as the canned sequence - the other controls are completely inconsistent though. reverse just makes the robot emit a whine, but it does not move. it will spin one way, but not the other. Follow me just doesn't work at all aside from making the yetiborg just jerk occasionally. I've connected a wii remote to the pi but although the example joystick control registers the remote as a joystick, pressing the buttons only makes a character appear on screen rather than moving the robot.

we are relatively new to the whole raspberry pi thing, and not experienced programmers, but I was hoping that the examples would allow him to work the robot so that he could then get into the programming side of it - but as it is it just doesn't work.

Am I doing something wrong? It seems odd to me that the movements the yetiborg makes with the canned sequence, which seem correct apart from only using 2wd for forward, do not match the movements that the web UI produces for what should be the same command.

It did occur to me that perhaps the examples file was corrupted during download, but reinstalling the software produces the same result.

Help please!

(sorry, I've just realised that the getting started forum I posted this in originally is archived)

piborg's picture

Not to worry, it is likely to be a simple problem which is easy to fix :)

Based on the description it sounds like the wiring between the motors and the ZeroBorg may be incorrect. We have seen this kind of mistake before with our MonsterBorg kit and in both cases it was easily fixed :)

The wiring on the ZeroBorg should be connected as follows:

  • M1+ is connected to the Black wire for the Rear Right motor
  • M1- is connected to the Red wire for the Rear Right motor
  • M2+ is connected to the Black wire for the Front Right motor
  • M2- is connected to the Red wire for the Front Right motor
  • V+ is unused
  • GND is unused
  • M3+ is connected to the Red wire for the Front Left motor
  • M3- is connected to the Black wire for the Front Left motor
  • M4+ is connected to the Red wire for the Rear Left motor
  • M4- is connected to the Black wire for the Rear left motor

Here are the motors shown from underneath with their corresponding numbers:

If you have a multimeter you can check these connections between the tabs on each motor and the large pads / pins on the underside of the ZeroBorg next to each label.

If you do not have a multimeter you will probably need to undo the four nuts on the top of the YetiBorg V2 so that you can carefully lower the ZeroBorg out and check the wiring connections by eye.

The most likely mistakes would be getting the black / red wires connected the wrong way around or accidentally connecting motors to the V+ or GND connectors which should not be connected to anything.

Ah ha. Yes, you are right despite me checking 3 times I appear to have mixed up the red wire from motor 2 with motor 3... Thank you!

However, it still doesn't reverse unless it is given a little push - I'm using a lithium ion 9v battery, is it possible that the current from the battery is insufficient?

piborg's picture

Glad to hear you have made some progress :)

The YetiBorg V2 does tend to provide a bit less power running in reverse due to how the speed control works. This should result in being a bit slower but still able to move.

The first thing to check is that the power settings in the scripts are correct for your battery. These are the default values:

# Power settings
voltageIn = 8.4                 # Total battery voltage to the ZeroBorg
voltageOut = 6.0                # Maximum motor voltage

The default of 8.4 V is correct for most NiMH or NiCad PP3 batteries, although some are 7.2 V or 9.6 V. They usually specify the actual voltage on the battery itself.

Typically LiPo or Lithium Ion batteries in the 9V / PP3 size and shape are actually 7.4 V. In this case the default value will be providing less power to the motors than it should in both the forward and reverse direction. Changing the voltageIn value in all of the examples should fix that :)

If you are using the script you can also try the boost button (default is L1 on a PS3 controller). This will ignore the battery settings while held and run at the full battery power temporarily. In this mode forward and reverse should be equally powerful / fast.

Perfect! Thanks for your help :)

Subscribe to Comments for "Yetiborg V2 problem"